IBM WebSphere Application Server 7.0 < 7.0.0.39 (FP39) / 8.0 < 8.0.0.11 (FP11) / 8.5 < 8.5.5.6 (FP6) Multiple Vulnerabilities (Bar Mitzvah) (FREAK)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote application server is affected by multiple vulnerabilities.

Description :

The IBM WebSphere Application Server running on the remote host is
version 7.0 prior to 7.0.0.39, 8.0 prior to 8.0.0.11, or 8.5 prior to
8.5.5.6. It is, therefore, potentially affected by multiple
vulnerabilities :

- A security feature bypass vulnerability, known as FREAK
(Factoring attack on RSA-EXPORT Keys), exists in the IBM
Global Security Kit (GSKit) due to the support of weak
EXPORT_RSA cipher suites with keys less than or equal to
512 bits. A man-in-the-middle attacker may be able to
downgrade the SSL/TLS connection to use EXPORT_RSA
cipher suites which can be factored in a short amount of
time, allowing the attacker to intercept and decrypt the
traffic. (CVE-2015-0138)

- An information disclosure vulnerability exists due to a
flaw in the Bleichenbacher countermeasure implementation
in Apache WSS4J. A remote attacker can exploit this, via
a crafted message, to determine where an encryption
failure to place, allowing the attacker to gain access
to the plaintext symmetric key. (CVE-2015-0226)

- An XML External Entity (XXE) vulnerability exists due to
an incorrectly configured XML parser that accepts XML
external entities from an untrusted source. A remote
attacker can exploit this, via specially crafted XML
data, to gain access to arbitrary files. (CVE-2015-0250)

- A privilege escalation vulnerability exists due to a
flaw that occurs in 'full' profile and 'liberty' profile
when using an OAuth grant password. A remote attacker
can exploit this to gain elevated privileges.
(CVE-2015-1885)

- A privilege escalation vulnerability exists due to
incorrect settings in the serveServletsbyClassname
functionality. A remote attacker can exploit this to
gain elevated privileges. (CVE-2015-1927)

- An information disclosure vulnerability exists that
allows an unauthenticated, remote attacker to identify
the proxy server software by reading the HTTP 'Via'
header. (CVE-2015-1932)

- An unspecified flaw exists in the administrative console
that allows a remote attacker, via the 'JSESSIONID'
parameter, to hijack a user's session. (CVE-2015-1936)

- A privilege escalation vulnerability exists due to an
unspecified flaw that occurs when handling user roles.
A local attacker can exploit this to gain elevated
privileges. (CVE-2015-1946)

- A security feature bypass vulnerability exists, known as
Bar Mitzvah, due to improper combination of state data
with key data by the RC4 cipher algorithm during the
initialization phase. A man-in-the-middle attacker can
exploit this, via a brute-force attack using LSB values,
to decrypt the traffic. (CVE-2015-2808)

- An unspecified flaw exists that allows an
unauthenticated, remote attacker to spoof servlets or
disclose sensitive information. (CVE-2015-4938)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21698613
http://www-01.ibm.com/support/docview.wss?uid=swg21959083
http://www-304.ibm.com/support/docview.wss?uid=swg27004980
http://www-01.ibm.com/support/docview.wss?uid=swg21963275
https://www.smacktls.com/#freak
http://www.nessus.org/u?4bbf45ac

Solution :

Apply IBM 7.0 Fix Pack 39 (7.0.0.39) / 8.0 Fix Pack 11 (8.0.0.11) /
8.5 Fix Pack 6 (8.5.5.6) or later. Alternatively, apply the Interim
Fixes as recommended in the vendor advisory.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now