OpenSSL 1.0.1 < 1.0.1p Multiple Vulnerabilities

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple vulnerabilities.

Description :

According to its banner, the remote host is running a version of
OpenSSL 1.0.1 prior to 1.0.1p. It is, therefore, affected by the
following vulnerabilities :

- A certificate validation bypass vulnerability exists due
to a flaw in the X509_verify_cert() function in
x509_vfy.c that is triggered when locating alternate
certificate chains when the first attempt to build such
a chain fails. A remote attacker can exploit this, by
using a valid leaf certificate as a certificate
authority (CA), to issue invalid certificates that will
bypass authentication. Note that this issue affects only
versions 1.0.1n and 1.0.1o. (CVE-2015-1793)

- A race condition exists in s3_clnt.c that is triggered
when PSK identity hints are incorrectly updated in the
parent SSL_CTX structure when they are received by a
multi-threaded client. A remote attacker can exploit
this, via a crafted ServerKeyExchange message, to cause
a double-free memory error, resulting in a denial of
service. (CVE-2015-3196)

See also :

https://www.openssl.org/news/secadv/20150709.txt
https://www.openssl.org/news/secadv/20151203.txt
http://www.nessus.org/u?fcde170c
http://www.nessus.org/u?59729200

Solution :

Upgrade to OpenSSL version 1.0.1p or later.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N)
CVSS Temporal Score : 5.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 84636 ()

Bugtraq ID: 75652

CVE ID: CVE-2015-1793
CVE-2015-3196

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now