Trihedral VTScada 6.5.x < 9.1.20 / 10.x < 10.2.22 / 11.x < 11.1.09 HTTP Server DoS

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

An application running on the remote host is affected by a denial of
service vulnerability.

Description :

The version of Trihedral Engineering VTScada installed on the remote
host is prior to 9.1.20, 10.x prior to 10.2.22, or 11.x prior to
11.1.09. It is, therefore, affected by a denial of service
vulnerability due to an integer overflow condition in the included
HTTP server. A remote, unauthenticated attacker, using a crafted
packet containing small negative content length, can exploit this
issue to trigger a large memory allocation, resulting in a server
crash.

See also :

http://www.trihedral.com/help/#Op_Welcome/Wel_UpgradeNotes.htm
https://ics-cert.us-cert.gov/advisories/ICSA-14-343-02

Solution :

Upgrade to Trihedral Engineering VTScada version 9.1.20 / 10.2.22 /
11.1.09 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)

Family: SCADA

Nessus Plugin ID: 84587 ()

Bugtraq ID: 71591

CVE ID: CVE-2014-9192

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now