FreeBSD : php5 -- multiple vulnerabilities (cdff0af2-1492-11e5-a1cf-002590263bf5)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

The PHP project reports :

DOM and GD :

- Fixed bug #69719 (Incorrect handling of paths with NULs).

FTP :

- Improved fix for bug #69545 (Integer overflow in ftp_genlist()
resulting in heap overflow). (CVE-2015-4643)

Postgres :

- Fixed bug #69667 (segfault in php_pgsql_meta_data). (CVE-2015-4644)

See also :

http://www.php.net/ChangeLog-5.php#5.4.42
http://www.php.net/ChangeLog-5.php#5.5.26
http://www.php.net/ChangeLog-5.php#5.6.10
http://openwall.com/lists/oss-security/2015/06/18/3
http://www.nessus.org/u?d1b7361d

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 84326 ()

Bugtraq ID:

CVE ID: CVE-2015-4643
CVE-2015-4644

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now