VMware Workstation 10.x < 10.0.6 / 11.x < 11.1.1 Multiple Vulnerabilities (VMSA-2015-0004) (Windows)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization application installed that is
affected by multiple vulnerabilities.

Description :

The version of VMware Workstation installed on the remote Windows host
is 10.x prior to 10.0.6 or 11.x prior to 11.1.1. It is, therefore,
affected by multiple vulnerabilities :

- An arbitrary code execution vulnerability exists due to
a stack-based buffer overflow condition in the JPEG2000
plugin that is triggered when parsing a Quantization
Default (QCD) marker segment in a JPEG2000 (JP2) image
file. A remote attacker can exploit this, using a
specially crafted image, to execute arbitrary code or
cause a denial of service condition. (CVE-2012-0897)

- Multiple unspecified remote code execution
vulnerabilities exists in 'TPView.dll' and 'TPInt.dll'
library files. (CVE-2015-2336, CVE-2015-2337)

- The 'TPview.dll' and 'TPInt.dll' library files fail to
properly handle memory allocation. A remote attacker can
exploit this to cause a denial of service.
(CVE-2015-2338, CVE-2015-2339, CVE-2015-2340)

See also :

http://www.vmware.com/security/advisories/VMSA-2015-0004.html

Solution :

Upgrade to VMware Workstation version 10.0.6 / 11.1.1 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 84223 ()

Bugtraq ID: 51426
75092
75095

CVE ID: CVE-2012-0897
CVE-2015-2336
CVE-2015-2337
CVE-2015-2338
CVE-2015-2339
CVE-2015-2340

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now