Scientific Linux Security Update : wpa_supplicant on SL7.x x86_64

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

A buffer overflow flaw was found in the way wpa_supplicant handled
SSID information in the Wi-Fi Direct / P2P management frames. A
specially crafted frame could allow an attacker within Wi-Fi radio
range to cause wpa_supplicant to crash or, possibly, execute arbitrary
code. (CVE-2015-1863)

An integer underflow flaw, leading to a buffer over-read, was found in
the way wpa_supplicant handled WMM Action frames. A specially crafted
frame could possibly allow an attacker within Wi-Fi radio range to
cause wpa_supplicant to crash. (CVE-2015-4142)

This update also adds the following enhancement :

- Prior to this update, wpa_supplicant did not provide a
way to require the host name to be listed in an X.509
certificate's Common Name or Subject Alternative Name,
and only allowed host name suffix or subject substring
checks. This update introduces a new configuration
directive, 'domain_match', which adds a full host name
check.

After installing this update, the wpa_supplicant service will be
restarted automatically.

See also :

http://www.nessus.org/u?9457f2be

Solution :

Update the affected wpa_supplicant and / or wpa_supplicant-debuginfo
packages.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 84144 ()

Bugtraq ID:

CVE ID: CVE-2015-1863
CVE-2015-4142

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now