SUSE SLES11 Security Update : php53 (SUSE-SU-2015:1018-1)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote SUSE host is missing one or more security updates.

Description :

PHP 5.3 was updated to fix multiple security issues :

bnc#931776: pcntl_exec() does not check path validity (CVE-2015-4026)

bnc#931772: overflow in ftp_genlist() resulting in heap overflow
(CVE-2015-4022)

bnc#931769: memory corruption in phar_parse_tarfile when entry
filename starts with NULL (CVE-2015-4021)

bnc#931421: multipart/form-data remote denial-of-service vulnerability
(CVE-2015-4024)

bnc#928511: buffer over-read in unserialize when parsing Phar
(CVE-2015-2783)

bnc#928506: buffer over flow when parsing tar/zip/phar in
phar_set_inode() (CVE-2015-3329)

bnc#925109: SoapClient's __call() type confusion through unserialize()

bnc#924972: use-after-free vulnerability in the process_nested_data
function (CVE-2015-2787)

bnc#923946: embedded gd copy: buffer read overflow in gd_gif_in.c
(CVE-2014-9709)

bnc#922452: built-in regular expression (regex) library contains a
heap overflow vulnerability (CVE-2015-2305)

bnc#922451: heap buffer overflow in enchant_broker_request_dict()
(CVE-2014-9705)

bnc#922022: php's built-in regular expression (regex) library contains
a heap overflow vulnerability (CVE-2015-2301)

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

https://bugzilla.suse.com/922022
https://bugzilla.suse.com/922451
https://bugzilla.suse.com/922452
https://bugzilla.suse.com/923946
https://bugzilla.suse.com/924972
https://bugzilla.suse.com/925109
https://bugzilla.suse.com/928506
https://bugzilla.suse.com/928511
https://bugzilla.suse.com/931421
https://bugzilla.suse.com/931769
https://bugzilla.suse.com/931772
https://bugzilla.suse.com/931776
http://www.nessus.org/u?d03cc6d1
https://www.suse.com/security/cve/CVE-2014-9705.html
https://www.suse.com/security/cve/CVE-2014-9709.html
https://www.suse.com/security/cve/CVE-2015-2301.html
https://www.suse.com/security/cve/CVE-2015-2305.html
https://www.suse.com/security/cve/CVE-2015-2783.html
https://www.suse.com/security/cve/CVE-2015-2787.html
https://www.suse.com/security/cve/CVE-2015-3329.html
https://www.suse.com/security/cve/CVE-2015-4021.html
https://www.suse.com/security/cve/CVE-2015-4022.html
https://www.suse.com/security/cve/CVE-2015-4024.html
https://www.suse.com/security/cve/CVE-2015-4026.html
http://www.nessus.org/u?48073445

Solution :

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 11 SP3 :

zypper in -t patch sdksp3-apache2-mod_php53=10716

SUSE Linux Enterprise Server 11 SP3 for VMware :

zypper in -t patch slessp3-apache2-mod_php53=10716

SUSE Linux Enterprise Server 11 SP3 :

zypper in -t patch slessp3-apache2-mod_php53=10716

To bring your system up-to-date, use 'zypper patch'.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now