Apache Tomcat 7.0.x < 7.0.59 Security Manager Bypass

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat server is affected by a security bypass
vulnerability.

Description :

According to its self-reported version number, the Apache Tomcat
server listening on the remote host is 7.0.x prior to 7.0.59. It is,
therefore, affected by a security bypass vulnerability due to a flaw
that occurs when handling expression language. A remote attacker can
exploit this, via a crafted web application, to bypass the security
manager protection and execute arbitrary code.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :

http://www.nessus.org/u?edd653ec
http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.59
http://seclists.org/bugtraq/2015/May/94

Solution :

Upgrade to Apache Tomcat version 7.0.59 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 83764 ()

Bugtraq ID: 74665

CVE ID: CVE-2014-7810

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now