Oracle VM VirtualBox < 3.2.28 / 4.0.30 / 4.1.38 / 4.2.30 / 4.3.28 QEMU FDC Overflow RCE (VENOM)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by a remote code
execution vulnerability.

Description :

The remote host contains a version of Oracle VM VirtualBox that is
prior to 3.2.28 / 4.0.30 / 4.1.38 / 4.2.30 / 4.3.28. It is, therefore
affected by a flaw in the Floppy Disk Controller (FDC) in the bundled
QEMU software due to an overflow condition in 'hw/block/fdc.c' when
handling certain commands. An attacker, with access to an account on
the guest operating system with privilege to access the FDC, can
exploit this flaw to execute arbitrary code in the context of the
hypervisor process on the host system.

See also :

http://www.nessus.org/u?2bd5df81
https://www.virtualbox.org/wiki/Changelog
http://venom.crowdstrike.com/

Solution :

Upgrade Oracle VM VirtualBox to 3.2.28 / 4.0.30 / 4.1.38 / 4.2.30 /
4.3.28 or later.

Risk factor :

High / CVSS Base Score : 7.7
(CVSS2#AV:A/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 83729 ()

Bugtraq ID: 74640

CVE ID: CVE-2015-3456

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now