IBM WebSphere Application Server Multiple Vulnerabilities

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote application server is affected by multiple vulnerabilities.

Description :

The IBM WebSphere Application Server running on the remote host is
version 6.1.0.47 / 7.0.0.37 / 8.0.0.10 / 8.5.5.5 or prior. It is,
therefore, affected by multiple vulnerabilities :

- An information disclosure vulnerability exists in the
SNMP component due to improper handling of configuration
data. An authenticated, remote attacker can exploit this
disclose sensitive information. (CVE-2015-0174)

- An unspecified flaw exists in the liberty profile due to
improper handling of authData elements. An
authenticated, remote attacker can exploit this to gain
elevated privileges. (CVE-2015-0175)

- An unspecified flaw exists in the liberty profile that
is triggered when the run-as user for EJB is not honored
under multi-threaded race conditions. An authenticated,
remote attacker can exploit this to gain elevated
privileges. (CVE-2015-1882)

- A flaw exists that allows a remote attacker to execute
arbitrary code by connecting to a management port using
a specific sequence of instructions. (CVE-2015-1920)

See also :

https://www-304.ibm.com/support/docview.wss?uid=swg21883573
https://www-304.ibm.com/support/docview.wss?uid=swg21697368
https://www-304.ibm.com/support/docview.wss?uid=swg24039898

Solution :

Apply Interim Fix PI38302.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 83290 ()

Bugtraq ID: 74215
74222
74223
74439

CVE ID: CVE-2015-0174
CVE-2015-0175
CVE-2015-1882
CVE-2015-1920

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now