Mandriva Linux Security Advisory : ruby (MDVSA-2015:224)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

Updated ruby packages fix security vulnerability :

Ruby OpenSSL hostname matching implementation violates RFC 6125
(CVE-2015-1855).

The ruby packages for MBS2 has been updated to version 2.0.0-p645,
which fixes this issue.

See also :

http://advisories.mageia.org/MGASA-2015-0178.html

Solution :

Update the affected packages.

Risk factor :

High

Family: Mandriva Local Security Checks

Nessus Plugin ID: 83248 ()

Bugtraq ID:

CVE ID: CVE-2015-1855

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now