Mac OS X : OS X Server < 4.1 Multiple Vulnerabilities (POODLE)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a security update for OS X Server.

Description :

The remote Mac OS X host has a version of OS X Server installed that
is prior 4.1. It is, therefore, affected by vulnerabilities in the
following components :

- Dovecot
- Firewall
- Postfix
- Wiki Server

See also :

http://support.apple.com/kb/HT204201
https://www.imperialviolet.org/2014/10/14/poodle.html
https://www.openssl.org/~bodo/ssl-poodle.pdf
https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Solution :

Upgrade to OS X Server version 4.1 or later.

Note that OS X Server 4.1 is available only for OS X 10.10 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 83088 ()

Bugtraq ID: 70574
74355
74356

CVE ID: CVE-2014-3566
CVE-2015-1150
CVE-2015-1151

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now