Mac OS X 10.10.x < 10.10.3 Multiple Vulnerabilities (FREAK)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a Mac OS X update that fixes multiple
security vulnerabilities.

Description :

The remote host is running a version of Mac OS X 10.10.x that is prior
to 10.10.3. It is, therefore, affected multiple vulnerabilities in the
following components :

- Admin Framework
- Apache
- ATS
- Certificate Trust Policy
- CFNetwork HTTPProtocol
- CFNetwork Session
- CFURL
- CoreAnimation
- FontParser
- Graphics Driver
- Hypervisor
- ImageIO
- IOHIDFamily
- Kernel
- LaunchServices
- libnetcore
- ntp
- Open Directory Client
- OpenLDAP
- OpenSSL
- PHP
- QuickLook
- SceneKit
- ScreenSharing
- Security - Code SIgning
- UniformTypeIdentifiers
- WebKit

Note that successful exploitation of the most serious issues can
result in arbitrary code execution.

See also :

http://support.apple.com/en-us/HT204659
http://www.nessus.org/u?cf90c4cb

Solution :

Upgrade to Mac OS X 10.10.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true