Firefox < 37.0 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Firefox installed on the remote Mac OS X host is prior
to 37.0. It is, therefore, affected by the following vulnerabilities :

- A privilege escalation vulnerability exists which
relates to anchor navigation. A remote attacker can
exploit this to bypass same-origin policy protections,
allowing a possible execution of arbitrary scripts in a
privileged context. Note that this is a variant of
CVE-2015-0818 that was fixed in Firefox 36.0.4.
(CVE-2015-0801)

- Access to certain privileged internal methods is
retained when navigating from windows created to contain
privileged UI content to unprivileged pages. An attacker
can exploit this to execute arbitrary JavaScript with
elevated privileges. (CVE-2015-0802)

- Multiple type confusion issues exist that can lead to
use-after-free errors, which a remote attacker can
exploit to execute arbitrary code or cause a denial of
service. (CVE-2015-0803, CVE-2015-0804)

- Multiple memory corruption issues exist related to Off
Main Thread Compositing when rendering 2D graphics,
which a remote attacker can exploit to execute arbitrary
code or cause a denial of service. (CVE-2015-0805,
CVE-2015-0806)

- A cross-site request forgery (XSRF) vulnerability exists
in the sendBeacon() function due to cross-origin
resource sharing (CORS) requests following 30x
redirections. (CVE-2015-0807)

- An issue exists in WebRTC related to memory management
for simple-style arrays, which may be used by a remote
attacker to cause a denial of service. (CVE-2015-0808)

- An issue exists that allows a remote attacker to make
the user's cursor invisible, possibly resulting in a
successful clickjacking attack. (CVE-2015-0810)

- An out-of-bounds read issue exists in the QCMS color
management library that could lead to an information
disclosure. (CVE-2015-0811)

- An issue exists that can allow a man-in-the-middle
attacker to bypass user-confirmation and install a
Firefox lightweight theme by spoofing a Mozilla
sub-domain. (CVE-2015-0812)

- Multiple memory safety issues exist within the browser
engine. A remote attacker can exploit these to corrupt
memory and possibly execute arbitrary code.
(CVE-2015-0814, CVE-2015-0815)

- A privilege escalation vulnerability exists related to
documents loaded through a 'resource:' URL. An attacker
can exploit this to load pages and execute JavaScript
with elevated privileges. (CVE-2015-0816)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2015-30/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-32/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-33/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-34/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-35/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-36/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-37/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-38/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-39/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-40/
https://www.mozilla.org/en-US/security/advisories/mfsa2015-42/

Solution :

Upgrade to Firefox 37.0 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now