openSUSE Security Update : libzip (openSUSE-2015-265)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Libzip was updated to fix one security issue.

A zip file with an unusually large number of entries could have caused
an integer overflow leading to a write past the heap boundary,
crashing the application. (CVE-2015-2331 bnc#923240)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=923240

Solution :

Update the affected libzip packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
Public Exploit Available : true

Family: SuSE Local Security Checks

Nessus Plugin ID: 82423 ()

Bugtraq ID:

CVE ID: CVE-2015-2331

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now