Mandriva Linux Security Advisory : gnupg (MDVSA-2015:154)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

Updated gnupg, gnupg2 and libgcrypt packages fix security
vulnerabilities :

GnuPG versions before 1.4.17 and 2.0.24 are vulnerable to a denial of
service which can be caused by garbled compressed data packets which
may put gpg into an infinite loop (CVE-2014-4617).

The libgcrypt library before version 1.5.4 is vulnerable to an ELGAMAL
side-channel attack (CVE-2014-5270).

GnuPG before 1.4.19 is vulnerable to a side-channel attack which can
potentially lead to an information leak (CVE-2014-3591).

GnuPG before 1.4.19 is vulnerable to a side-channel attack on
data-dependent timing variations in modular exponentiation, which can
potentially lead to an information leak (CVE-2015-0837).

The gnupg and gnupg2 package has been patched to correct these issues.

GnuPG2 is vulnerable to these issues through the libgcrypt library.
The issues were fixed in libgcrypt 1.6.3. The libgcrypt package in
Mandriva, at version 1.5.4, was only vulnerable to the CVE-2014-3591
issue. It has also been patched to correct this issue.

See also :

http://advisories.mageia.org/MGASA-2014-0276.html
http://advisories.mageia.org/MGASA-2014-0365.html
http://advisories.mageia.org/MGASA-2015-0104.html

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 82407 ()

Bugtraq ID:

CVE ID: CVE-2014-3591
CVE-2014-4617
CVE-2014-5270
CVE-2015-0837

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now