Mandriva Linux Security Advisory : e2fsprogs (MDVSA-2015:067)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

Updated e2fsprogs packages fix security vulnerabilities :

The libext2fs library, part of e2fsprogs and utilized by its
utilities, is affected by a boundary check error on block group
descriptor information, leading to a heap based buffer overflow. A
specially crafted filesystem image can be used to trigger the
vulnerability (CVE-2015-0247).

The libext2fs library, part of e2fsprogs and utilized by its
utilities, is affected by a boundary check error on block group
descriptor information, leading to a heap based buffer overflow. A
specially crafted filesystem image can be used to trigger the
vulnerability. This is due to an incomplete fix for CVE-2015-0247
(CVE-2015-1572).

See also :

http://advisories.mageia.org/MGASA-2015-0061.html
http://advisories.mageia.org/MGASA-2015-0088.html

Solution :

Update the affected e2fsprogs, lib64ext2fs-devel and / or lib64ext2fs2
packages.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 82320 ()

Bugtraq ID:

CVE ID: CVE-2015-0247
CVE-2015-1572

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now