FreeBSD : libzip -- integer overflow (264749ae-d565-11e4-b545-00269ee29e57)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

libzip developers report :

Avoid integer overflow. Fixed similarly to patch used in PHP copy of
libzip.

See also :

https://bugs.php.net/bug.php?id=69253
http://www.nessus.org/u?81d0b92a
http://hg.nih.at/libzip/rev/9f11d54f692e
http://www.nessus.org/u?1a1758b5

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
Public Exploit Available : true

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 82313 ()

Bugtraq ID:

CVE ID: CVE-2015-2331

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now