openSUSE Security Update : chromium (openSUSE-2015-228)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Chromium was updated to 41.0.2272.76 (bnc#920825)

Security fixes :

- CVE-2015-1212: Out-of-bounds write in media

- CVE-2015-1213: Out-of-bounds write in skia filters

- CVE-2015-1214: Out-of-bounds write in skia filters

- CVE-2015-1215: Out-of-bounds write in skia filters

- CVE-2015-1216: Use-after-free in v8 bindings

- CVE-2015-1217: Type confusion in v8 bindings

- CVE-2015-1218: Use-after-free in dom

- CVE-2015-1219: Integer overflow in webgl

- CVE-2015-1220: Use-after-free in gif decoder

- CVE-2015-1221: Use-after-free in web databases

- CVE-2015-1222: Use-after-free in service workers

- CVE-2015-1223: Use-after-free in dom

- CVE-2015-1230: Type confusion in v8

- CVE-2015-1224: Out-of-bounds read in vpxdecoder

- CVE-2015-1225: Out-of-bounds read in pdfium

- CVE-2015-1226: Validation issue in debugger

- CVE-2015-1227: Uninitialized value in blink

- CVE-2015-1228: Uninitialized value in rendering

- CVE-2015-1229: Cookie injection via proxies

- CVE-2015-1231: Various fixes from internal audits

- Multiple vulnerabilities in V8 fixed at the tip of the
4.1 branch

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=920825

Solution :

Update the affected chromium packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now