openSUSE Security Update : flash-player (openSUSE-2015-225)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Adobe Flash Player was updated to 11.2.202.451 (bsc#922033).

These security issues were fixed :

- Memory corruption vulnerabilities that could lead to
code execution (CVE-2015-0332, CVE-2015-0333,
CVE-2015-0335, CVE-2015-0339).

- Type confusion vulnerabilities that could lead to code
execution (CVE-2015-0334, CVE-2015-0336).

- A vulnerability that could lead to a cross-domain policy
bypass (CVE-2015-0337).

- A vulnerability that could lead to a file upload
restriction bypass (CVE-2015-0340).

- An integer overflow vulnerability that could lead to
code execution (CVE-2015-0338).

- Use-after-free vulnerabilities that could lead to code
execution (CVE-2015-0341, CVE-2015-0342).

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=922033

Solution :

Update the affected flash-player packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now