Flash Player For Mac <= 16.0.0.305 Multiple Vulnerabilities (APSB15-05)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the Adobe Flash Player installed on the
remote Mac OS X host is equal or prior to version 16.0.0.305. It is,
therefore, affected by the following vulnerabilities :

- Multiple memory corruption issues exist due to not
properly validating user input, which an attacker can
exploit to execute arbitrary code. (CVE-2015-0332,
CVE-2015-0333, CVE-2015-0335, CVE-2015-0339)

- Multiple type confusions flaws exist, which an attacker
can exploit to execute arbitrary code. (CVE-2015-0334,
CVE-2015-0336)

- An unspecified flaw exists that allows an attacker to
bypass cross-domain policy. (CVE-2015-0337)

- An integer overflow condition exists due to not properly
validating user input, which an attacker can exploit to
execute arbitrary code. (CVE-2015-0338)

- An unspecified flaw exists that allows an attacker to
bypass restrictions and upload arbitrary files.
(CVE-2015-0340)

- Multiple use-after-free errors exist that can allow an
attacker to deference already freed memory and execute
arbitrary code. (CVE-2015-0341, CVE-2015-0342)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb15-05.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 17.0.0.134 or later.

Alternatively, Adobe has made version 13.0.0.277 available for those
installations that cannot be upgraded to 17.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now