Apple Xcode < 6.2 (Mac OS X)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by
multiple vulnerabilities.

Description :

The Apple Xcode installed on the remote Mac OS X host is prior to
version 6.2. It is, therefore, affected by the following
vulnerabilities :

- Numerous errors exist related to the bundled version of
Apache Subversion. (CVE-2014-3522, CVE-2014-3528,
CVE-2014-3580, CVE-2014-8108)

- An error exists related to the bundled version of Git
that allows arbitrary files to be added to the .git
folder. (CVE-2014-9390)

See also :

https://support.apple.com/en-us/HT204427
http://www.nessus.org/u?2d35c04b

Solution :

Upgrade to Apple Xcode version 6.2 or later, which is available for OS
X 10.9.4 (Mavericks) or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 81758 ()

Bugtraq ID: 68995
69237
71725
71726
71732

CVE ID: CVE-2014-3522
CVE-2014-3528
CVE-2014-3580
CVE-2014-8108
CVE-2014-9390

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now