Advantech ADAMView Multiple Buffer Overflow Vulnerabilities

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple buffer overflow
vulnerabilities.

Description :

Advantech ADAMView, an HMI software development kit, is installed on
the remote host. It is, therefore, affected by multiple stack-based
buffer overflow vulnerabilities. A remote attacker, using specially
crafted display properties or GNI files, can exploit these to execute
arbitrary code.

See also :

https://ics-cert.us-cert.gov/alerts/ICS-ALERT-14-323-02

Solution :

There is currently no fix available.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 7.5
(CVSS2#E:ND/RL:U/RC:ND)
Public Exploit Available : true

Family: SCADA

Nessus Plugin ID: 81700 ()

Bugtraq ID: 71191

CVE ID: CVE-2014-8386

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now