Wireshark 1.10.x < 1.10.13 / 1.12.x < 1.12.4 Multiple DoS Vulnerabilities

This script is Copyright (C) 2015 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains an application that is affected by
multiple denial of service vulnerabilities.

Description :

The version of Wireshark installed remote Windows host is 1.10.x prior
to 1.10.13, or 1.12.x prior to 1.12.4. It is, therefore, affected by
denial of service vulnerabilities in the following items :

- ATN-CPDLC dissector (CVE-2015-2187)
- WCP dissector (CVE-2015-2188)
- pcapng file parser (CVE-2015-2189)
- LLDP dissector (CVE-2015-2190)
- TNEF dissector (CVE-2015-2191)
- SCSI OSD dissector (CVE-2015-2192)

A remote attacker can exploit these vulnerabilities to cause Wireshark
to crash or consume excessive CPU resources, either by injecting a
specially crafted packet onto the wire or by convincing a user to read
a malformed packet trace or PCAP file.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Wireshark version 1.12.4 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now