Apache Tomcat 7.0.x < 7.0.57 Multiple Vulnerabilities (POODLE)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat server is affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the Apache Tomcat
service listening on the remote host is 7.0.x prior to 7.0.57. It is,
therefore, affected by the following vulnerabilities :

- A memory double-free error exists in 'd1_both.c' related
to handling DTLS packets that allows denial of service
attacks. (CVE-2014-3505)

- An unspecified error exists in 'd1_both.c' related to
handling DTLS handshake messages that allows denial of
service attacks due to large amounts of memory being
consumed. (CVE-2014-3506)

- A memory leak error exists in 'd1_both.c' related to
handling specially crafted DTLS packets that allows
denial of service attacks. (CVE-2014-3507)

- An error exists in the 'OBJ_obj2txt' function when
various 'X509_name_*' pretty printing functions are
used, which leak process stack data, resulting in an
information disclosure. (CVE-2014-3508)

- An error exists related to 'ec point format extension'
handling and multithreaded clients that allows freed
memory to be overwritten during a resumed session.
(CVE-2014-3509)

- A NULL pointer dereference error exists related to
handling anonymous ECDH cipher suites and crafted
handshake messages that allows denial of service attacks
against clients. (CVE-2014-3510)

- An error exists related to handling fragmented
'ClientHello' messages that allows a man-in-the-middle
attacker to force usage of TLS 1.0 regardless of higher
protocol levels being supported by both the server and
the client. (CVE-2014-3511)

- Buffer overflow errors exist in 'srp_lib.c' related to
handling Secure Remote Password protocol (SRP)
parameters, which can allow a denial of service or have
other unspecified impact. (CVE-2014-3512)

- A memory leak issue exists in 'd1_srtp.c' related to
the DTLS SRTP extension handling and specially crafted
handshake messages that can allow denial of service
attacks. (CVE-2014-3513)

- An error exists related to the way SSL 3.0 handles
padding bytes when decrypting messages encrypted using
block ciphers in cipher block chaining (CBC) mode.
Man-in-the-middle attackers can decrypt a selected byte
of a cipher text in as few as 256 tries if they are able
to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections. This
is also known as the 'POODLE' issue. (CVE-2014-3566)

- A memory leak issue exists in 't1_lib.c' related to
session ticket handling that can allow denial of service
attacks. (CVE-2014-3567)

- An error exists related to the build configuration
process and the 'no-ssl3' build option that allows
servers and clients to process insecure SSL 3.0
handshake messages. (CVE-2014-3568)

- A NULL pointer dereference error exists in 't1_lib.c',
related to handling Secure Remote Password protocol
(SRP) ServerHello messages, which allows a malicious
server to crash a client, resulting in a denial of
service. (CVE-2014-5139)

Note that Nessus has not attempted to exploit these issues but has
instead relied only on the application's self-reported version number.

See also :

http://tomcat.apache.org/tomcat-7.0-doc/changelog.html
https://www.imperialviolet.org/2014/10/14/poodle.html
https://www.openssl.org/~bodo/ssl-poodle.pdf
https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Solution :

Update to Apache Tomcat version 7.0.57 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now