Privoxy < 3.0.23 Multiple DoS Vulnerabilities

This script is Copyright (C) 2015 Tenable Network Security, Inc.

Synopsis :

The remote web proxy is affected by multiple denial of service

Description :

According to its self-reported version number, the version of Privoxy
running on the remote host is prior to 3.0.23. It is, therefore,
potentially affected by multiple denial of service vulnerabilities :

- A flaw exists in the chunked_body_is_complete() function
in 'jcc.c' due to improper processing of invalid
chunk-encoded bodies. A remote attacker, using a
specially crafted client request, can cause the Privoxy
instance to abort. (CVE-2015-1380)

- Multiple flaws exist in the pcrs_compile_replacement()
function in 'pcrs.c' when handling backreferences.
Remote attackers can exploit these flaws to cause a
segmentation fault or memory consumption.

- An invalid read flaw in 'parsers.c' allows a remote
attacker, via an HTTP request with a specially-crafted
time header, to cause a denial of service condition.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

Solution :

Upgrade to Privoxy version 3.0.23 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 81516 ()

Bugtraq ID: 72354

CVE ID: CVE-2015-1380

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now