Privoxy < 3.0.23 Multiple DoS Vulnerabilities

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote web proxy is affected by multiple denial of service
vulnerabilities.

Description :

According to its self-reported version number, the version of Privoxy
running on the remote host is prior to 3.0.23. It is, therefore,
potentially affected by multiple denial of service vulnerabilities :

- A flaw exists in the chunked_body_is_complete() function
in 'jcc.c' due to improper processing of invalid
chunk-encoded bodies. A remote attacker, using a
specially crafted client request, can cause the Privoxy
instance to abort. (CVE-2015-1380)

- Multiple flaws exist in the pcrs_compile_replacement()
function in 'pcrs.c' when handling backreferences.
Remote attackers can exploit these flaws to cause a
segmentation fault or memory consumption.
(CVE-2015-1381)

- An invalid read flaw in 'parsers.c' allows a remote
attacker, via an HTTP request with a specially-crafted
time header, to cause a denial of service condition.
(CVE-2015-1382)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://sourceforge.net/p/ijbswa/mailman/message/33089172/
http://www.nessus.org/u?02038803
http://www.nessus.org/u?e70b2d80
http://www.nessus.org/u?fc0894c2

Solution :

Upgrade to Privoxy version 3.0.23 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 81516 ()

Bugtraq ID: 72354
72355
72360

CVE ID: CVE-2015-1380
CVE-2015-1381
CVE-2015-1382

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now