SuSE 11.3 Security Update : php53 (SAT Patch Number 10313)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote SuSE 11 host is missing one or more security updates.

Description :

PHP 5.3 was updated to fix three security issues :

- Use-after-free vulnerability allowed remote attackers to
execute arbitrary code via a crafted unserialize call
that leveraged improper handling of duplicate keys
within the serialized properties of an object.
(bnc#910659). (CVE-2014-8142)

- Use-after-free vulnerability allowed remote attackers to
execute arbitrary code via a crafted unserialize call
that leveraged improper handling of duplicate numerical
keys within the serialized properties of an object.
NOTE: this vulnerability exists because of an incomplete
fix for CVE-2014-8142. (bnc#910659). (CVE-2015-0231)

- The exif_process_unicode function allowed remote
attackers to execute arbitrary code or cause a denial of
service (uninitialized pointer free and application
crash) via crafted EXIF data in a JPEG image.
(bnc#914690). (CVE-2015-0232)

Additionally a fix was included that protects against a possible NULL
pointer use. (bnc#910659)

This non-security issue has been fixed :

- Don't ignore default_socket_timeout on outgoing SSL
connection (bnc#907519)

See also :

https://bugzilla.novell.com/show_bug.cgi?id=907519
https://bugzilla.novell.com/show_bug.cgi?id=910659
https://bugzilla.novell.com/show_bug.cgi?id=914690
http://support.novell.com/security/cve/CVE-2014-8142.html
http://support.novell.com/security/cve/CVE-2015-0231.html
http://support.novell.com/security/cve/CVE-2015-0232.html

Solution :

Apply SAT patch number 10313.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 81507 ()

Bugtraq ID:

CVE ID: CVE-2014-8142
CVE-2015-0231
CVE-2015-0232

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now