RHEL 5 / 6 : Red Hat Satellite IBM Java Runtime (RHSA-2015:0264) (POODLE)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated java-1.6.0-ibm packages that fix several security issues are
now available for Red Hat Satellite 5.6.

Red Hat Product Security has rated this update as having Low security
impact. Common Vulnerability Scoring System (CVSS) base scores, which
give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

This update corrects several security vulnerabilities in the IBM Java
Runtime Environment shipped as part of Red Hat Satellite 5.6. In a
typical operating environment, these are of low security risk as the
runtime is not used on untrusted applets.

Several flaws were fixed in the IBM Java 2 Runtime Environment.
(CVE-2014-3065, CVE-2014-3068, CVE-2014-3566, CVE-2014-4209,
CVE-2014-4218, CVE-2014-4219, CVE-2014-4227, CVE-2014-4244,
CVE-2014-4252, CVE-2014-4262, CVE-2014-4263, CVE-2014-4265,
CVE-2014-4288, CVE-2014-6457, CVE-2014-6458, CVE-2014-6492,
CVE-2014-6493, CVE-2014-6502, CVE-2014-6503, CVE-2014-6506,
CVE-2014-6511, CVE-2014-6512, CVE-2014-6515, CVE-2014-6531,
CVE-2014-6532, CVE-2014-6558, CVE-2014-6585, CVE-2014-6587,
CVE-2014-6591, CVE-2014-6593, CVE-2014-8891, CVE-2014-8892,
CVE-2015-0395, CVE-2015-0403, CVE-2015-0406, CVE-2015-0407,
CVE-2015-0408, CVE-2015-0410, CVE-2015-0412)

The CVE-2014-4262 and CVE-2014-6512 issues were discovered by Florian
Weimer of Red Hat Product Security.

Users of Red Hat Satellite 5.6 are advised to upgrade to these updated
packages, which contain the IBM Java SE 6 SR16-FP3 release. For this
update to take effect, Red Hat Satellite must be restarted
('/usr/sbin/rhn-satellite restart'), as well as all running instances
of IBM Java.

See also :

https://www.redhat.com/security/data/cve/CVE-2014-3065.html
https://www.redhat.com/security/data/cve/CVE-2014-3068.html
https://www.redhat.com/security/data/cve/CVE-2014-3086.html
https://www.redhat.com/security/data/cve/CVE-2014-3566.html
https://www.redhat.com/security/data/cve/CVE-2014-4209.html
https://www.redhat.com/security/data/cve/CVE-2014-4218.html
https://www.redhat.com/security/data/cve/CVE-2014-4219.html
https://www.redhat.com/security/data/cve/CVE-2014-4227.html
https://www.redhat.com/security/data/cve/CVE-2014-4244.html
https://www.redhat.com/security/data/cve/CVE-2014-4252.html
https://www.redhat.com/security/data/cve/CVE-2014-4262.html
https://www.redhat.com/security/data/cve/CVE-2014-4263.html
https://www.redhat.com/security/data/cve/CVE-2014-4265.html
https://www.redhat.com/security/data/cve/CVE-2014-4288.html
https://www.redhat.com/security/data/cve/CVE-2014-6457.html
https://www.redhat.com/security/data/cve/CVE-2014-6458.html
https://www.redhat.com/security/data/cve/CVE-2014-6492.html
https://www.redhat.com/security/data/cve/CVE-2014-6493.html
https://www.redhat.com/security/data/cve/CVE-2014-6502.html
https://www.redhat.com/security/data/cve/CVE-2014-6503.html
https://www.redhat.com/security/data/cve/CVE-2014-6506.html
https://www.redhat.com/security/data/cve/CVE-2014-6511.html
https://www.redhat.com/security/data/cve/CVE-2014-6512.html
https://www.redhat.com/security/data/cve/CVE-2014-6515.html
https://www.redhat.com/security/data/cve/CVE-2014-6531.html
https://www.redhat.com/security/data/cve/CVE-2014-6532.html
https://www.redhat.com/security/data/cve/CVE-2014-6558.html
https://www.redhat.com/security/data/cve/CVE-2014-6585.html
https://www.redhat.com/security/data/cve/CVE-2014-6587.html
https://www.redhat.com/security/data/cve/CVE-2014-6591.html
https://www.redhat.com/security/data/cve/CVE-2014-6593.html
https://www.redhat.com/security/data/cve/CVE-2014-8891.html
https://www.redhat.com/security/data/cve/CVE-2014-8892.html
https://www.redhat.com/security/data/cve/CVE-2015-0395.html
https://www.redhat.com/security/data/cve/CVE-2015-0403.html
https://www.redhat.com/security/data/cve/CVE-2015-0406.html
https://www.redhat.com/security/data/cve/CVE-2015-0407.html
https://www.redhat.com/security/data/cve/CVE-2015-0408.html
https://www.redhat.com/security/data/cve/CVE-2015-0410.html
https://www.redhat.com/security/data/cve/CVE-2015-0412.html
https://www.ibm.com/developerworks/java/jdk/alerts/
http://rhn.redhat.com/errata/RHSA-2015-0264.html

Solution :

Update the affected java-1.6.0-ibm and / or java-1.6.0-ibm-devel
packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.5
(CVSS2#E:U/RL:U/RC:C)
Public Exploit Available : false