Mandriva Linux Security Advisory : perl-Gtk2 (MDVSA-2015:044)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability has been discovered and corrected in perl-Gtk2 :

Incorrect memory management in Gtk2::Gdk::Display::list_devices in
perl-Gtk2 before 1.2495, where, the code was freeing memory that gtk+
still holds onto and might access later.

The updated packages have been patched to correct this issue.

See also :

http://advisories.mageia.org/MGASA-2015-0059.html

Solution :

Update the affected perl-Gtk2 and / or perl-Gtk2-doc packages.

Risk factor :

High

Family: Mandriva Local Security Checks

Nessus Plugin ID: 81333 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now