VMware Workstation 10.x < 10.0.5 Multiple Vulnerabilities (VMSA-2015-0001 / VMSA-2015-0004) (Windows)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization application installed that is
affected by multiple vulnerabilities.

Description :

The version of VMware Workstation installed on the remote Windows host
is 10.x prior to 10.0.5. It is, therefore, affected by multiple
vulnerabilities :

- An unspecified flaw exists that allows a local attacker
to escalate privileges or cause a denial of service
via an arbitrary write to a file. (CVE-2014-8370)

- An input validation error exists in the Host Guest File
System (HGFS) that allows a local attacker to cause a
denial of service of the guest operating system.
(CVE-2015-1043)

- An input validation error exists in the VMware
Authorization process (vmware-authd) that allows a
remote attacker to cause a denial of service of the host
operating system. (CVE-2015-1044)

- A denial of service vulnerability exists due to improper
validation of user-supplied input to a remote procedure
call (RPC) command. An unauthenticated, remote attacker
can exploit this, via a crafted command, to crash the
host or guest operating systems. (CVE-2015-2341)

See also :

http://www.nessus.org/u?3bded33c
http://www.vmware.com/security/advisories/VMSA-2015-0001.html
http://www.vmware.com/security/advisories/VMSA-2015-0004.html

Solution :

Upgrade to VMware Workstation version 10.0.5 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.8
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 81187 ()

Bugtraq ID: 72336
72337
72338
75094

CVE ID: CVE-2014-8370
CVE-2015-1043
CVE-2015-1044
CVE-2015-2341

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now