Google Chrome < 40.0.2214.93 Flash Player Multiple Remote Code Execution (Mac OS X)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple remote code execution vulnerabilities.

Description :

The version of Google Chrome installed on the remote Mac OS X host is
prior to 40.0.2214.93. It is, therefore, affected by the following
vulnerabilities :

- A use-after-free error exists that allows an attacker to
crash the application or execute arbitrary code.
(CVE-2015-0311)

- A double-free error exists that allows an attacker to
crash the application or possibly execute arbitrary
code. (CVE-2015-0312)

See also :

http://www.nessus.org/u?d2bec23e
https://helpx.adobe.com/security/products/flash-player/apsb15-03.html

Solution :

Upgrade to Google Chrome 40.0.2214.93 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 81021 ()

Bugtraq ID: 72283
72343

CVE ID: CVE-2015-0311
CVE-2015-0312

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now