FreeBSD : libutp -- remote denial of service or arbitrary code execution (0523fb7e-8444-4e86-812d-8de05f6f0dce)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

NVD reports :

Stack-based buffer overflow in utp.cpp in libutp, as used in
Transmission before 2.74 and possibly other products, allows remote
attackers to cause a denial of service (crash) and possibly execute
arbitrary code via crafted 'micro transport protocol packets.'

See also :

https://github.com/bittorrent/libutp/issues/38
https://trac.transmissionbt.com/ticket/5002
http://www.nessus.org/u?fb4be8e5

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 80923 ()

Bugtraq ID:

CVE ID: CVE-2012-6129

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now