Samba 4.x < 4.0.24 / 4.1.16 UF_SERVER_TRUST_ACCOUNT AD DC Privilege Escalation

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by a privilege escalation
vulnerability.

Description :

According to its banner, the version of Samba on the remote host is
4.x prior to 4.0.24 / 4.1.16. It is, therefore, affected by a flaw in
the Active Directory Domain Controller (AD DC) component due to a
failure to implement a required check on the 'UF_SERVER_TRUST_ACCOUNT'
bit of the 'userAccountControl' attributes. This vulnerability could
allow a remote, authenticated attacker to elevate privileges.

Note that this issue only affects Samba installations acting as Active
Directory Domain Controllers that allow delegation for the creation of
user or computer accounts.

Also note that Nessus has not tested for this issue but has instead
relied only on the application's self-reported version number.

See also :

https://www.samba.org/samba/security/CVE-2014-8143.html
http://www.nessus.org/u?3f3a3084
http://www.nessus.org/u?8c7d41bf

Solution :

Install the patch referenced in the project's advisory or upgrade to
4.0.24 / 4.1.16 or later.

Alternatively, as a workaround, do not delegate permission to create
users or computers to entities other than Domain Administrators.

Risk factor :

High / CVSS Base Score : 8.5
(CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.3
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 80916 ()

Bugtraq ID: 72278

CVE ID: CVE-2014-8143

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now