Apache Subversion 1.7.x < 1.7.19 / 1.8.x < 1.8.11 Multiple Remote DoS

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple remote denial of service
vulnerabilities.

Description :

The remote host is running a version of Apache SVN 1.7.x prior to
1.7.19 or 1.8.x prior to 1.8.11. It is, therefore, affected by
multiple denial of service vulnerabilities :

- A NULL pointer dereference flaw exists in 'mod_dav_svn'
that is triggered when handling REPORT requests. A
remote attacker, using a specially crafted request, can
cause the listener process to crash. (CVE-2014-3580)

- A NULL pointer dereference flaw exists in 'mod_dav_svn'
that is triggered when handling requests for
non-existent virtual transaction names. A remote
attacker, using a specially crafted request, can cause
the listener process to crash. (CVE-2014-8108)

See also :

http://subversion.apache.org/security/CVE-2014-3580-advisory.txt
http://subversion.apache.org/security/CVE-2014-8108-advisory.txt

Solution :

Upgrade to Subversion 1.7.19 / 1.8.11 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 80864 ()

Bugtraq ID: 71725
71726

CVE ID: CVE-2014-3580
CVE-2014-8108

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now