Oracle Solaris Third-Party Patch Update : ruby (multiple_cryptographic_issues_vulnerabilities_in)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Solaris system is missing a security patch for third-party
software.

Description :

The remote Solaris system is missing necessary patches to address
security updates :

- Algorithmic complexity vulnerability in
Gem::Version::VERSION_PATTERN in lib/
rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24
through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before
2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows
remote attackers to cause a denial of service (CPU
consumption) via a crafted gem version that triggers a
large amount of backtracking in a regular expression.
(CVE-2013-4287)

- Algorithmic complexity vulnerability in
Gem::Version::ANCHORED_VERSION_PATTERN in
lib/rubygems/version.rb in RubyGems before 1.8.23.2,
1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x
before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247,
allows remote attackers to cause a denial of service
(CPU consumption) via a crafted gem version that
triggers a large amount of backtracking in a regular
expression. NOTE: this issue is due to an incomplete fix
for CVE-2013-4287. (CVE-2013-4363)

See also :

http://www.nessus.org/u?b5f8def1
http://www.nessus.org/u?ebef2e27

Solution :

Upgrade to Solaris 11.1.14.5.0.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: Solaris Local Security Checks

Nessus Plugin ID: 80756 ()

Bugtraq ID:

CVE ID: CVE-2013-4287
CVE-2013-4363

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now