Oracle Solaris Third-Party Patch Update : bash (cve_2012_3410_stack_based)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Solaris system is missing a security patch for third-party
software.

Description :

The remote Solaris system is missing necessary patches to address
security updates :

- Stack-based buffer overflow in lib/sh/eaccess.c in GNU
Bash before 4.2 patch 33 might allow local users to
bypass intended restricted shell access via a long
filename in /dev/fd, which is not properly handled when
expanding the /dev/fd prefix. (CVE-2012-3410)

See also :

http://www.nessus.org/u?b5f8def1
https://blogs.oracle.com/sunsecurity/entry/cve_2012_3410_stack_based

Solution :

Upgrade to Solaris 11.1.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Solaris Local Security Checks

Nessus Plugin ID: 80591 ()

Bugtraq ID:

CVE ID: CVE-2012-3410

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now