OpenSSL 1.0.1 < 1.0.1k Multiple Vulnerabilities (FREAK)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by multiple vulnerabilities.

Description :

According to its banner, the remote web server uses a version of
OpenSSL 1.0.1 prior to 1.0.1k. The OpenSSL library is, therefore,
affected by the following vulnerabilities :

- A NULL pointer dereference flaw exists when the SSLv3
option isn't enabled and an SSLv3 ClientHello is
received. This allows a remote attacker, using an
unexpected handshake, to crash the daemon, resulting in
a denial of service. (CVE-2014-3569)

- The BIGNUM squaring (BN_sqr) implementation does not
properly calculate the square of a BIGNUM value. This
allows remote attackers to defeat cryptographic
protection mechanisms. (CVE-2014-3570)

- A NULL pointer dereference flaw exists with
dtls1_get_record() when handling DTLS messages. A remote
attacker, using a specially crafted DTLS message, can
cause a denial of service. (CVE-2014-3571)

- A flaw exists with ECDH handshakes when using an ECDSA
certificate without a ServerKeyExchange message. This
allows a remote attacker to trigger a loss of forward
secrecy from the ciphersuite. (CVE-2014-3572)

- A flaw exists when accepting non-DER variations of
certificate signature algorithms and signature encodings
due to a lack of enforcement of matches between signed
and unsigned portions. A remote attacker, by including
crafted data within a certificate's unsigned portion,
can bypass fingerprint-based certificate-blacklist
protection mechanisms. (CVE-2014-8275)

- A security feature bypass vulnerability, known as FREAK
(Factoring attack on RSA-EXPORT Keys), exists due to the
support of weak EXPORT_RSA cipher suites with keys less
than or equal to 512 bits. A man-in-the-middle attacker
may be able to downgrade the SSL/TLS connection to use
EXPORT_RSA cipher suites which can be factored in a
short amount of time, allowing the attacker to intercept
and decrypt the traffic. (CVE-2015-0204)

- A flaw exists when accepting DH certificates for client
authentication without the CertificateVerify message.
This allows a remote attacker to authenticate to the
service without a private key. (CVE-2015-0205)

- A memory leak occurs in dtls1_buffer_record()
when handling a saturation of DTLS records containing
the same number sequence but for the next epoch. This
allows a remote attacker to cause a denial of service.
(CVE-2015-0206)

See also :

https://www.openssl.org/news/openssl-1.0.1-notes.html
https://www.openssl.org/news/secadv/20150108.txt
https://www.openssl.org/news/vulnerabilities.html
https://www.smacktls.com/#freak

Solution :

Upgrade to OpenSSL 1.0.1k or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now