Flash Player For Mac <= 16.0.0.235 Multiple Vulnerabilities (APSB15-01)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the installation of Adobe Flash Player
installed on the remote Mac OS X host is equal or prior to 16.0.0.235.
It is, therefore, affected by the following vulnerabilities :

- An unspecified improper file validation issue.
(CVE-2015-0301)

- An unspecified information disclosure vulnerability,
which can be exploited to capture keystrokes.
(CVE-2015-0302)

- Multiple memory corruption vulnerabilities allow an
attacker to execute arbitrary code. (CVE-2015-0303,
CVE-2015-0306)

- Multiple heap-based buffer overflow vulnerabilities
that can be exploited to execute arbitrary code.
(CVE-2015-0304, CVE-2015-0309)

- An unspecified type confusion vulnerability that can
lead to code execution. (CVE-2015-0305)

- An out-of-bounds read vulnerability that can be
exploited to leak memory addresses. (CVE-2015-0307)

- A use-after-free vulnerability that results in arbitrary
code execution. (CVE-2015-0308)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb15-01.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 16.0.0.257 or later.

Alternatively, Adobe has made version 13.0.0.260 available for those
installations that cannot be upgraded to 16.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now