Adobe Shockwave Player <= 12.0.0.112 Multiple Vulnerabilities (APSB13-12) (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe Shockwave Player
that is equal to or prior than 12.0.0.112. It is, therefore, affected
by the following vulnerabilities :

- An unspecified buffer overflow exists. (CVE-2013-1383)

- Two unspecified memory corruption errors exist.
(CVE-2013-1384, CVE-2013-1386)

- A memory leak error exists that weakens address space
randomization. (CVE-2013-1385)

A remote attacker can exploit these issues by tricking a user into
viewing a malicious Shockwave file, resulting in arbitrary code
execution.

See also :

http://www.adobe.com/support/security/bulletins/apsb13-12.html

Solution :

Upgrade to Adobe Shockwave Player 12.0.2.122 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 80184 ()

Bugtraq ID: 58980
58982
58983
58984

CVE ID: CVE-2013-1383
CVE-2013-1384
CVE-2013-1385
CVE-2013-1386

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now