Adobe Shockwave Player <= 11.6.1.629 Multiple Memory Corruption Vulnerabilities (APSB11-27) (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe Shockwave Player
that is 11.6.1.629 or earlier. It is, therefore, affected by multiple
memory corruption vulnerabilities.

A remote attacker can exploit these issues by tricking a user into
viewing a malicious Shockwave file, resulting in arbitrary code
execution.

See also :

http://www.adobe.com/support/security/bulletins/apsb11-27.html

Solution :

Upgrade to Adobe Shockwave 11.6.3.633 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 80178 ()

Bugtraq ID: 50581
50583
50584
50586

CVE ID: CVE-2011-2446
CVE-2011-2447
CVE-2011-2448
CVE-2011-2449

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now