Adobe Shockwave Player <= 11.6.0.626 Multiple Memory Corruption Vulnerabilities (APSB11-19) (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe's Shockwave
Player that is 11.6.0.626 or earlier. As such, it is potentially
affected by multiple memory corruption vulnerabilities.

A remote attacker could exploit these issues by tricking a user into
viewing a malicious Shockwave file, resulting in arbitrary code
execution.

See also :

http://dvlabs.tippingpoint.com/advisory/TPTI-11-14
http://www.adobe.com/support/security/bulletins/apsb11-19.html

Solution :

Upgrade to Adobe Shockwave 11.6.1.629 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 80177 ()

Bugtraq ID: 49102

CVE ID: CVE-2010-4308
CVE-2010-4309
CVE-2011-2419
CVE-2011-2420
CVE-2011-2421
CVE-2011-2422
CVE-2011-2423

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now