Adobe Shockwave Player <= 11.5.8.612 (APSB10-25) (Mac OS X)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe Shockwave Player
that is 11.5.8.612 or earlier. It is, therefore, affected by multiple
vulnerabilities :

- A memory corruption issue exists that allows code
execution. Note that there are reports that this issue
is being exploited in the wild. (CVE-2010-3653)

- A heap-based buffer overflow vulnerability allows code
execution. (CVE-2010-2582)

- Multiple memory corruption issues in the 'dirapi.dll'
module allow code execution. (CVE-2010-2581,
CVE-2010-3655, CVE-2010-4084, CVE-2010-4085,
CVE-2010-4086, CVE-2010-4088)

- Multiple memory corruption issues in the 'IML32.dll'
module allow code execution. (CVE-2010-4087,
CVE-2010-4089)

- A memory corruption issue allows code execution.
(CVE-2010-4090)

See also :

http://www.adobe.com/support/security/bulletins/apsb10-25.html

Solution :

Upgrade to Adobe Shockwave 11.5.9.615 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now