Adobe Shockwave Player <= 11.5.2.602 Multiple Vulnerabilities (APSB10-03) (Mac OS X)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe Shockwave Player
that is 11.5.2.602 or earlier. It is, therefore, affected by multiple
vulnerabilities :

- A buffer overflow vulnerability allows code execution.
(CVE-2009-4002)

- Multiple integer overflow vulnerabilities that allow
code execution. (CVE-2009-4003)

See also :

http://www.adobe.com/support/security/bulletins/apsb10-03.html

Solution :

Upgrade to Adobe Shockwave version 11.5.6.606 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 80171 ()

Bugtraq ID: 37870
37872

CVE ID: CVE-2009-4002
CVE-2009-4003

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now