ESXi 5.1 < Build 2323231 glibc Library Multiple Vulnerabilities (remote check)

This script is (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote VMware ESXi 5.1 host is affected by multiple
vulnerabilities.

Description :

The remote VMware ESXi host is version 5.1 prior to build 2323231. It
is, therefore, affected by the following vulnerabilities in the glibc
library :

- A buffer overflow flaw exists in the 'extend_buffers'
function of the 'posix/regexec.c' file due to improper
validation of user input. Using a specially crafted
expression, a remote attacker can cause a denial of
service. (CVE-2013-0242)

- A buffer overflow flaw exists in the 'getaddrinfo'
function of the '/sysdeps/posix/getaddrinfo.c' file
due to improper validation of user input. A remote
attacker can cause a denial of service by triggering
a large number of domain conversions. (CVE-2013-1914)

See also :

http://www.vmware.com/security/advisories/VMSA-2014-0008.html

Solution :

Apply patch ESXi510-201412101-SG for ESXi 5.1.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 80037 ()

Bugtraq ID: 57638
58839

CVE ID: CVE-2013-0242
CVE-2013-1914

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now