Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2014-3103)

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote Oracle Linux host is missing one or more security updates.

Description :

Description of changes:

kernel-uek
[3.8.13-55.1.1.el7uek]
- ALSA: control: Protect user controls against concurrent access
(Lars-Peter Clausen) [Orabug: 20192540] {CVE-2014-4652}
- target/rd: Refactor rd_build_device_space + rd_release_device_space
(Nicholas Bellinger) [Orabug: 20192516] {CVE-2014-4027}
- HID: logitech: perform bounds checking on device_id early enough (Jiri
Kosina) [Orabug: 20192477] {CVE-2014-3182}
- udf: Avoid infinite loop when processing indirect ICBs (Jan Kara)
[Orabug: 20192448] {CVE-2014-6410}
- ALSA: control: Make sure that id->index does not overflow (Lars-Peter
Clausen) [Orabug: 20192416] {CVE-2014-4656}
- ALSA: control: Handle numid overflow (Lars-Peter Clausen) [Orabug:
20192367] {CVE-2014-4656}
- HID: picolcd: sanity check report size in raw_event() callback (Jiri
Kosina) [Orabug: 20192208] {CVE-2014-3186}
- net: sctp: fix remote memory pressure from excessive queueing (Daniel
Borkmann) [Orabug: 20192058] {CVE-2014-3688}

See also :

https://oss.oracle.com/pipermail/el-errata/2014-December/004715.html
https://oss.oracle.com/pipermail/el-errata/2014-December/004716.html

Solution :

Update the affected unbreakable enterprise kernel packages.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Oracle Linux Local Security Checks

Nessus Plugin ID: 80004 ()

Bugtraq ID: 68159
68163
68170
69763
69770
69799
70768

CVE ID: CVE-2014-3182
CVE-2014-3186
CVE-2014-3688
CVE-2014-4027
CVE-2014-4652
CVE-2014-4656
CVE-2014-6410

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now