Flash Player <= 15.0.0.239 Multiple Vulnerabilities (APSB14-27)

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the installation of Adobe Flash Player
installed on the remote Windows host is equal or prior to 15.0.0.239.
It is, therefore, affected by the following vulnerabilities :

- A security bypass vulnerability that allows an attacker
to bypass the same-origin policy. (CVE-2014-0580)

- Multiple memory corruption vulnerabilities that allow an
attacker to execute arbitrary code. (CVE-2014-0587,
CVE-2014-9164)

- A use-after-free vulnerability that can result in
arbitrary code execution. (CVE-2014-8443)

- An unspecified information disclosure vulnerability.
(CVE-2014-9162)

- A stack-based buffer overflow vulnerability that can be
exploited to execute arbitrary code or elevate
privileges. (CVE-2014-9163)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb14-27.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 16.0.0.235 or later.

Alternatively, Adobe has made version 13.0.0.259 available for those
installations that cannot be upgraded to 16.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now