Squid 3.x < 3.4.8 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.

Synopsis :

The remote proxy server may be affected by multiple vulnerabilities.

Description :

According to its banner, the version of Squid running on the remote
host is 3.x prior to 3.4.8. Therefore, it may be affected by the
following vulnerabilities :

- A off-by-one overflow flaw exists within the SNMP
processing component. By using a specially crafted
UDP SNMP request, a remote attacker could exploit this
to cause a denial of service or possibly execute
arbitrary code. (CVE-2014-6270)

- There exists an array indexing flaw in the node pinger
that is triggered when parsing ICMP and ICMPv6 replies,
which may allow a remote attacker to crash the pinger or
obtain sensitive information. (CVE-2014-7141)

- The node pinger has a flaw in function 'Icmp4::Recv' in
file 'icmp/Icmp4.cc.' that is triggered when parsing
ICMP or ICMPv6 responses. A remote attacker could
exploit this to crash the pinger or obtain sensitive
information. (CVE-2014-7142)

Note that Nessus has relied only on the version in the proxy server's
banner. The patch released to address the issue does not update the
version in the banner. If the patch has been applied properly, and the
service has been restarted, consider this to be a false positive.

See also :


Solution :

Upgrade to Squid version 3.4.8 or later, or apply the vendor-supplied

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : false

Family: Firewalls

Nessus Plugin ID: 79742 ()

Bugtraq ID: 69686

CVE ID: CVE-2014-6270

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now