AIX rsyslog Advisory : rsyslog_advisory.asc

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote AIX host has a vulnerable version of rsyslog.

Description :

The version of rsyslog installed on the remote AIX host is affected by
a remote code execution or denial of service vulnerability :

- The installed rsyslog allows remote attackers to cause a
denial of service (crash), possibly execute arbitrary
code, or have other unspecified impacts by crafting a
priority (PRI) value that triggers an out-of-bounds
array access. (CVE-2014-3634)

- The original fix for the above issue still retained a
denial of service vulnerability when large PRI values
were encountered. (CVE-2014-3683)

See also :

http://aix.software.ibm.com/aix/efixes/security/rsyslog_advisory.asc

Solution :

A fix is available and can be downloaded from the AIX website.

To extract the fixes from the tar file :

tar xvf rsyslog_fix.tar

IMPORTANT : it is recommended that a mksysb backup of the system be
created if possible. Verify that it is both bootable and readable
before proceeding.

To preview the fix installation :

installp -a -d rsyslog.base -p all

To install the fix package :

installp -a -d rsyslog.base -X all

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: AIX Local Security Checks

Nessus Plugin ID: 79660 ()

Bugtraq ID: 70187
70243

CVE ID: CVE-2014-3634
CVE-2014-3683

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now