Mandriva Linux Security Advisory : perl-Plack (MDVSA-2014:235)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing a security update.

Description :

Updated perl-Plack package fixes security vulnerability :

Plack::App::File would previously strip trailing slashes off provided
paths. This in combination with the common pattern of serving files
with Plack::Middleware::Static could allow an attacker to bypass a
whitelist of generated files (CVE-2014-5269).

See also :

http://advisories.mageia.org/MGASA-2014-0486.html

Solution :

Update the affected perl-Plack package.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Mandriva Local Security Checks

Nessus Plugin ID: 79631 ()

Bugtraq ID: 69185

CVE ID: CVE-2014-5269

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now