Mandriva Linux Security Advisory : phpmyadmin (MDVSA-2014:228)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing a security update.

Description :

Multiple vulnerabilities has been discovered and corrected in
phpmyadmin :

- Multiple XSS vulnerabilities (CVE-2014-8958).

- Local file inclusion vulnerability (CVE-2014-8959).

- XSS vulnerability in error reporting functionality
(CVE-2014-8960).

- Leakage of line count of an arbitrary file
(CVE-2014-8961).

This upgrade provides the latest phpmyadmin version (4.2.12) to
address these vulnerabilities.

See also :

http://sourceforge.net/p/phpmyadmin/news/
http://www.phpmyadmin.net/home_page/security/PMASA-2014-13.php
http://www.phpmyadmin.net/home_page/security/PMASA-2014-14.php
http://www.phpmyadmin.net/home_page/security/PMASA-2014-15.php
http://www.phpmyadmin.net/home_page/security/PMASA-2014-16.php

Solution :

Update the affected phpmyadmin package.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 79588 ()

Bugtraq ID: 71243
71244
71245
71247

CVE ID: CVE-2014-8958
CVE-2014-8959
CVE-2014-8960
CVE-2014-8961

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now